Windows freezes at select keyboard screen, using WoA

#1

When the Windows setup runs, I’m stuck on the select keybord layout screen, I can’t select anything. And it freezes right as soon as the select keyboard layout screen appears. What do I do?

About the Help & Troubleshooting category
#2

Mine does this as well, first a few BSOD’s, then i land on the keyboard layout screen and freezes.
I’m trying to run this on a Raspberry 3 model B, even with no usb devices connected.

#3

Yo utilice WoR y añadí los controladores del USB y ethernet con la versión 17763 en una micro sd Sandisk Extreme A1. Tengo los dos modelo de raspberry 3 ( Model B y el Model B+) y en ambos me funcionan con la misma micro sd. Hay que tener en cuenta que el windows arm para el raspberry es un Windows To Go y por ello con usar la misma micro sd en varios raspberry del modelo 3 funcionaria.


#4

I have the same issue … I see all language to select but its freeze. I have try an other keyboard and mouse … not working .

#5

don’t plug in the keyboard/Mouse until after the setup screen comes up

#6

I did, it still froze

#7

Usé el WoR pero fue peor, ni siquiera llegué a la pantalla de diseño del teclado

#8

Is this with the latest USB driver’s from Core 1.4.0?

#9

I used WoA, and I think I did.

#10

Please check your power supply. It has to power the CPU and the external devices. You have to be very careful, because either the CPU can cause USB power to sag, or USB can cause CPU power to sag. Things will crash if you’re not careful. (I’m told some Japanese blog posts say that Vcc must always be in 5.04V to 5.08V or the CPU won’t be happy.) An externally powered hub is strongly recommended during initial testing, so you avoid this variable. (Pi -> Hub -> other devices).

#11

Wait so you mean, a USB hub plugged into the RPi, after setup starts?

#12

Not after setup starts, before setup starts. Plug the hub between the Pi and your kbd/mouse, etc. Leave it there throughout setup. This is just to isolate your pi from the USB power demands, which are not trivial in the context of the Pi.

#13

Kk, will it work for WoR???

#14

I’ve updated the WoR imager to support the new drivers.
It should work properly now. Make sure to use the latest UEFI.

#16

This shows up every single time with the WoR

#17

You’ll have to re-install Windows. Don’t disconnect the power cable during the first boot process.

Use the GPT partition scheme this time.

1 Like
#19

What do I replace with the gpt?

#20

Choose “GUID Partition Table (GPT)” instead of “Master Boot Record (MBR)” as the partition scheme at the configuration page.

#21

I went back to using WoA and now I’m just waiting for it to start. If that doesn’t, then I’ll do it how you suggested. Thx!

1 Like
#22

I’ve got the same issue here. Stuck at select keyboard layout. Tried all the possible resolutions listed above and still no luck.
Has anyone gotten past this issue?
Thanks