WiFi dongle testing

#1

I’m dedicating this thread to WiFi dongles and testing. Anyone who has tested is welcome to specify the model number as well as any additional information they may have regarding the hardware.

I’ve ordered the following and will be testing when it arrives on Wednesday:

#2

I have that exact dongle, but haven’t tested it on Windows 10. I will see if I can find it and let you know how it works.

1 Like
#3

Sounds good! I got it for 5.99 refurbished with Prime so I couldn’t pass it up. It seems like it will work with our setup based on the data sheet from the manufacturer’s website. It may need drivers, but they’re available. Time will tell…

2 Likes
#4

This USB WiFi adapter carries the Realtek RTL8188CUS chip. If it were to work for you, it might serve as a reference. I have tried several wifi usb devices and none of them has worked for me. Some with Realtek chipset and others with Mediatek.
Luck!

#5

we need a wifi driver that is compatible with Windows 10 ARM

edit : maybe we can make a wifi driver for internal wifi raspberry pi 3. because I found a wifi driver sample for Windows 10 ARM & desktop

link:

Note: this driver must be modified to work on the internal WiFi Raspberry and compile it into the Inf file

I tried to build the WLAN driver (WiFi) without modification. but I got an error when building driver

#6

The Raspberry Pi 3 Model B + carries the Cypress CYW43455 chip and the Pi 3 uses Cypress CYW43438. Maybe you find some information on the manufacturer’s website.

https://www.cypress.com/news/cypress-delivers-robust-wireless-connectivity-raspberry-pi-3-model-b-iot-single-board-computer

#7

i found driver for WIFI Raspberry pi 3 b+ from this link
https://community.cypress.com/docs/DOC-14597

but is for linux :expressionless:

#8

Hi,

The WiFi driver there is for SDIO, and depends on an vendor specific HAL shipped as a .lib only.

It just won’t work.

The number of builtin WiFi drivers through USB on ARM64 Windows is exactly ZERO, don’t even try!

#9

Evidence for this? It might be low, but low is not equal to zero.

If at first you don’t succeed…

#10

There is no WiFi over USB driver present at all. It’s just not there.

#11

Yes, but it is amazing how many things are truly plug-n-play. You might be surprised…

#12

That’s why I’m going to test this other one when it comes tomorrow. I think it may actually work, but I guess we’ll find out!

#13

Atheros AR9271 not working
Realtek RTL8723B not working
MediaTek RT2870 does not work
Ralink RT5370 does not work
Ralink RT2070L not working
I continue with more tests …



#14

Wow you have a lot of stuff!! Thank you for all of the testing you’ve done.

1 Like
#15

Thank you! , but time is my worst enemy. I keep testing things.

#16

I know how that goes!:grin:

#17

@Oky12 https://docs.microsoft.com/en-us/windows-hardware/drivers/develop/building-arm64-drivers

#18

Inbox drivers don’t exist, based on earlier research. Need to see if some vendor has ARM64 drivers on website.

#19

I tried it but it still failed

#20

My Surface Pro USB Wired Nic did work out of the Box on the PI 3 and I would not have thought that would have been included - maybe the Surface Pro wireless Chipset Maxell would work?