MCCI USB driver status 2019-02-11

#83

Not annoying at all. I ran into the same thing. I’m installing a new image with a driver pack that I put together to see if it works. If not then we’ll have to wait for someone to post a guide. If my method works I’ll post it.

#84

Great Can’t wait to see some guide or your method to come out well. Can’t wait for this as it seems to be becoming a pretty good device, legitimately, to run simple programs like Paint.NET and stuff like that. Somebody should mod some sort of TV or something with this in it and it would be a pretty good internet-only device (once the ethernet works) for libraries and stuff. Can’t wait!

#85

It’s a no-go on my end. We’ll have to wait and see how. Desperately hoping someone will post tonight on this. I’m very eager to try these out. I’ll continue to experiment for now. I have a new image being installed now.

#86

I have the “drv” folder and all that stuff, so I just wanted to ask what the procedure is that you are doing? Just inject them into the drivers folder or something? Do I somehow inject them using WoA Imager or this tool? If it’s just not something worth doing I won’t do it and wait for a guide or something which HOPEFULLY will come out tonight!

#87

Interesting. He isn’t under USB devices in that screenshot. These must have to be installed a very specific way because they’re showing right under the BCMSPI Controller

#88

Hello! I can confirm that USB now works without any immediate problems. :smile:
What I did to make USB work: Extract the driver pack, delete the dwusb folder, replace it with the mcci driver folder (don’t move stuff under arm64/* to the same folder as the .inf and .cat - leave the folder structure as-is.), and go through Mario’s installer.

2 Likes
#89

Would you be able to post the driver structure from windows with it installed? I just formatted again and would love to be able to do it without doing so again. If you can’t then would you post the driver pack?

#90

The mcci drivers gets installed at C:\Windows\System32\drivers\mcci_dwchsotg_{hcd,usb}.sys
I basically unzipped the driver pack, ran the mcci installer, grabbed the ‘drv’ folder from the pi64-2.22 folder, deleted the dwusb folder from the extracted driver pack, placed the ‘drv’ folder in the extracted driver pack folder, renamed the drv folder to mcciusb, rezipped the extracted pack, and ran through the WoR installer.

#91

I’m just gonna go ahead and do that. I tried it before and had installation failed, but I also put all of the files into one folder. I’ll try it without moving them this time.

#92

One thing to note is that the lan9500 driver still didn’t load after installation - investigating now.

#93

I’m on a 3B+ anyway. I installed my LAN driver manually through device manager last time without issues.

#94

Just installing with modified driver pack. I’ll update when it’s working.

split this topic #95

4 posts were split to a new topic: On-board Ethernet

#99

I almost fell off of my chair when my wireless mouse worked. This is AMAZING!!!

split this topic #100

2 posts were split to a new topic: USB Driver Test Results

#101

could you guide me on how to install the Ethernet drivers im using a raspberry pi 3 B+

#102

To encourage creation of new topics rather than an ever-longer thread of interesting but diverging discussions, I’m setting this particular topic to close at 6pm today.

split this topic #103

A post was split to a new topic: How do I use DISM?

#104

Bye this topic! You will be remembered.

closed #105

This topic was automatically closed after 9 hours. New replies are no longer allowed.