Known working builds?

#1

What are the known working windows 10 builds that are still available on Microsoft’s server ?

#2

https://uup.rg-adguard.net/ - That’s the site. 17127 and 17134 both work. Last time I tried to download 17134 it worked just fine.

1 Like
#3

I’ve read that one used 18237, but no idea whether that’s good or not.

Most use 17134.

Blockquote
Graham Green (Telegram Group):
oh wow USB is working in the OOBE in 17763
BSOD hmmm ok i guess 17663 is not good for the rpi3

Blockquote
Googulator (Telegram Group)
E.g. eMMC read errors during boot are fatal on Lumias in 17763, but 17134 just retries until it succeeds

Blockquote
https://github.com/andreiw/RaspberryPiPkg
Builds 17125-17134, 17672 are known to work.

Next week I have time for my Raspberry Pi. I will then report which versions I have tested.

1 Like
#4

I usually recommend the build 17763.
It’s quite stable.

EDIT: Don’t use it! It’s cursed. I’ll BSOD while loading the Windows Setup (OOBE)

1 Like
#5

Where can I download 17763? It isn’t on http://uup.rg-adguard.net

#6

I’m actually working on it now. I found a link to that one. It’s going to be a while though. I’ll upload and host it once I get it all done.

#7

It is available on that website.

#8

It is, but I get an error every time. I think I saw that some other people were as well. I found a link actually. It has the business and consumer versions. Business is the first one on the page and Consumer is the fourth one down. https://cloud.mail.ru/public/9JdJ/Qe5Lm67QK/English/

UPDATE 1: The business version is what you want for a fresh install. The ISO loads just fine and you can pick which version you want. I’m currently installing Pro on a new SD card to test. I’ll also be testing if the consumer version can be mounted as an ISO and Windows can be installed from it as an update to 17134 which is currently on my other card.

UPDATE 2: The setup cannot run via a mounted ISO due to the UEFI layout. I’ve also had an error with a failed installation when running the business ISO on the installer. Not sure if it’s on my end, but it seems to be incompatible. I’m just confused because people have had this version work. This is a 4 in 1 ISO though so I’m assuming that it’s different. I’ll try it one more time and give one last update as to whether or not its working since I’m redoing it now.

UPDATE 3: My apologies. This download is a no-go. If anyone has the original ISO for 17763, you’re welcome to send it to me and I’ll host it on here for everyone. I’ll stick with 17134 for now.

UPDATE 4: Ignore everything else. It was on my end that the error occurred. Windows installs with either version. I used the consumer version in the installer (not the mounted ISO) and it installed without issues after everything was sorted out on my PC. I’m booting up now into 17673 without errors. Sorry for all of the random updates, but it may help if anyone has issues themselves. The link is good and I have the files saved in case they disappear and I need to host them.

FINAL UPDATE: It does not work. I’m not sure how anyone got this version working, but the ISO must have been different. Everything goes fine until you get to the intro screen where it says “Please wait” and it crashes. Do NOT use this ISO. I apologize for the confusion.

1 Like
#9

Saved me a lot of hassle, tho weirdly , I can’t even get the damned version to download…

#10

I can host these if anyone wants to experiment with them. In fact if anyone has known and I mean KNOWN working builds I can host all of them. I’ll separate them into stable and experimental. I’d just have to have them sent over to me first.

#11

I have Windows 10 build 17763.107 working properly. I got it from this link https://uupdump.ml/latest.php?dark=1
note: use the insider slow ring to choose build


I installed the windows using a tool made by @SuperJMN
https://github.com/WoA-project/WoA-Installer/blob/master/Docs/Raspberry.md

3 Likes
#12

Excellent work! So glad that somebody found this.

#13

I keep getting crashing with driver issues using the most current core package. Weird.

#14

Really? Because I discovered this and tried installing last night, and it was failing and blue-screening repeatedly.

#15

That’s my issue too.

#16

17763 (which supposedly works) + Core Package 1.2 = Failure.

In my case, it would sit at “Getting ready…” for ~5 minutes, then a blank screen for another ~5 minutes, and then a blue screen would appear for about 1/5 of a second (no joke) before immediately disappearing and trying to restart (although this also fails and hangs, I think I read somewhere that the USB driver interferes with rebooting).

I am switching to 17134 + Core Package 1.1 to see what happens. I will post the results of how that goes soon.

#17

I don’t know if this is relevant, but in the Core Package 1.1 the SD-card loader is “arisanSD” or something like that, whereas in 1.2 it is “uSD.” Something around how the SD card loads changed. Also in 1.2, the “Exiting UEFI and booting OS Kernel!” message does not appear, whereas it does in 1.1. I’m more concerned about the SD Card (driver?) change.

EDIT: I have successfully got to Windows Setup on 17134 + Core 1.1.

1 Like
#18

I keep getting crashing with driver issues using the most current core package. Weird.

there may be a corrupt file after the Windows installation to the SD card. because it happened to me in the same build. I have tried experimenting by changing the tool. driver. and uefi. but this problem was resolved after I used the wimlib and MBR scheme in the Windows tool on Raspberry imager. and also I check corrupt data with the CHKDSK command in cmd

note: inside the core package it uses old UEFI and drivers. so my advice. use the drivers and uefi that you think work

edit : for uSD controller use the default controller (broadcom). because I tried arasan it was slow

#19

Just go into the bios and change it to arisanSD and it will work in CORE1.2

#20

Please, don’t use 17763 (Windows 10 Version 1809)

It will BSOD (Blue screen) while loading the Windows Setup.

I’m using 17134 and it works quite fine.