Can we boot from a USB HDD?

it looks like we can boot Windows via external drive. but as said by @Daniel911. when using an external drive, some oddities appear

A way we could fix problem one could be this: or

Problem 2 might just be USB overhead. Not much we can do about that.

The extra RAM, I think, is because “no paging file”. Windows would normally page your executables in on demand; as a side effect of no paging file, it will read your entire executable, and it has nowhere to page out extra RAM. This might be fixable. But it’s a code change, not an INF change.

Coloquen una micro sd vacía (fat 32) y un disco duro externo USB (msata) con el sistema y el archivo de paginación lo crea en la micro sd.

1 Like

I can’t read spanish, but the translation is about “Place an empty sd micro (fat 32) and a USB external hard drive (msata) with the system and the paging file creates it in the micro sd.” That is the best idea so far, using the microSD as a paging file and booting via USB.


So what’s the verdict: is it faster with the best USB 2 hard drive or faster using SD Card with current drivers? Can you play Youtube videos smoothly with either arrangement?

No you can’t as everything is rendered via software

Could someone explain how to get windows to boot off usb I’m not sure how to go about doing this.

1 Like

To operate from the USB you have to modify the USB drivers (MCCI USB driver). In my case, I modified the .inf where it says StartType = 3 I put StartType = 0. You can do it with Notepad ++. You must have a micro sd in fat32 format to create the paging file.
I’m sorry for the English, I use the google translator.

1 Like

Thank you it worked! How would I go about setting up a paging file RAM usage is high

I’ll be posting a video on how to do this later tonight.

That’d be great, thanks!

How-to video has been posted in a new topic:

I’ve tried with he modified drivers (StartType=0) and when I choose my SSD, it blinks and returns to the UEFI shell :frowning:

I had that issue once. I had to redo the UEFI on my SD card. I ended up copying the UEFI files from the BOOT partition on the SSD and overwrote the ones on the card. It’s either the BOOT on the SSD or on the SD card. That’s where the problem is. Also, try going into Boot manager and selecting the SSD manually instead of changing the boot order. I had an issue with that once as well. In addition to that, you can delete UEFI shell from the boot options which will not give it the option to boot there. I deleted boot from everything except the SSD and it worked perfectly.

1 Like

Thanks for your directions, Anthony.

I re-deployed the UEFIs of both (SD Card and SSD) and removed all the boot options but the SSD. After that, I manually chose to boot the SSD. No worky :frowning:

Glad to hear it! I was worried that I over-complicated things, but I wanted it to be in as much detail as possible.

Sorry, I have explained myself wrong. I mean that “it’s not working”.

I usually say “no worky” as a funny way to say it.

So, I’m stuck with USB booting.

for USB booting. I don’t use tools like WOA or WOR. but using manual methods (CMD). and that work for me

Can you describe your method?