WOA on RPI3B+ Project 1709

#1

To stand any chance of practical use and productivity, Windows 10 version 1709 is by far the quickest and fastest to use on the Raspberry Pi! The problem is that Firefox Nightly doesn’t launch by default, and the latest cumulative update is causing a BSOD. So my project is to try to find a compromise in terms of successfully getting the newest installable cumulative update where possible onto the build to fix Firefox issue and then stripping away at the unneeded services, so that we are left with the speediest build possible coupled with RAM usage comparable to Linux! And I think the Home version will be better than the Professional for this, but then we cannot have Bitlocker. There is also Enterprise edition. I even managed to get S (cloud) version to work briefly, but the SD card and audio drivers don’t work. That seemed even quicker, but cannot run non-native apps.

1 Like
#2

I heard one of the mods or one of the users round here tried Windows 10 Home and it wouldn’t activate, but when the Troubleshoot button was pressed they were updated to Pro then activated. Can’t confirm if this is apparent on 1709, though.
My current build is running as fast as the build’s have gone on my Pi, i’ve got a 3B+ with Windows 10 Pro N with the “Small Optimization Script” (helped a lot) with 128GB microSD card. There’s a few problems, though as 128GB is as much as the Pi can handle (maybe too much) because Window’s Storage menu thinks it’s a 256GB card and the other non existent virtual 128GB is used by “System.”
Thanks to all the helpful users here who created the script, what to disable, pagefile fixes, etc. and I feel this will be very helpful in your doing of this project.

1 Like
#3

I was the one who said that home got upgraded to pro (which works for me, free upgrade woop!)
I’m also happy the script helped a lot for you!

Oh, and @gilius would you mind trying this version of Firefox? I had issues on 1709 after re-enabling memory compression, then I installed it again using this EXE from my thumb drive, and it’s now working. (I have NOT updated it from this version)

#4

The RPI3B + may be too slow with Windows. The jetson nano is at least 10 times faster, but I don’t know if it’s compatible enough. Is there someone who tried to install windows in jetson nano?

#5

I have used the WOA deployer and when I get to the screen to pick my keyboard layout I can’t get the keyboard to let me select anything. I have tried a few USB keyboards and none of them will work. I also took the SD card and put it into another Raspi and have the same issue.
Running a Pi 3B+ if that makes a difference. I agreed to the terms on the USB drivers. When I plug the keyboard in it doesn’t power the lights etc. The keyboard works fine to get into the settings, but when I move forward to the windows boot it doesn’t see it.
I have tried the 1903 and the 1809 versions of Windows on ARM64 with the same result.
I’m going to now try the 1709 version and see if it recognizes the keyboard…

#6

Use 1809, it’s what I’m using right now. The keyboard doesn’t work until setup is finished although it is detected, just use a mouse. I found old Logitech mice work and Dell keyboards + mice work after setup, but most work on start.