Win10 ARM64 on RPi4B Local Network

Has anyone successfully managed to gain ethernet control of their RPi4B on Win10 via OTG adapter from another machine?

I understand there are currently no network drivers for Win10 ARM64 on RPi4B and am aware of the current table of working/not working drivers https://github.com/worproject/RPi-Windows-Drivers

However, I have read of a couple people managing a network via RDP, OTG, USB-C cabling.

I am using the following:

and by following Marcin’s guide to install it:
https://rpi4-uefi.dev/win10-arm64-on-pi-4b/?unapproved=33&moderation-hash=e4c0431def7ab46dbce6cc08e0c8a058#comment-33

I’m just wondering if there is anyone out there who has managed to control their RPi4B from their main computer this way.

If anyone can supply any knowledge or advice as to how I can achieve this, that would be much appreciated.

Thanks!

I don’t know if that is as you said, I get into ethernet by smart phone (share network by USB) and install firefox successful.

  • RaspberryPi 4B
  • Windows 10 build 19624 pre-release
  • Smart phone connect to USB hub and setting “share my network by USB” at smart phone.
  • Remote control by TeamViewer

I also test by the config:

  • Smart phone close data transmission and set share my network by bluetooth
  • RaspberryPi 4B + bluetooth-> pair with smart phone
  • PC + bluetooth ->pair with smart phone
  • check PC and RaspberryPi 4B at the same local network, then Remote control by win10 default SW

smart phone become a local network hub by bluetooth network.

Interesting. So how are you getting this if there are no bluetooth or network drivers available for the RaspberryPi 4? My RPi4 will recognise smart phone, however will not appear in Network & internet settings. There are no Bluetooth options either.

I use 2 different bluetooth 4.0 USB Dongle, both of them use CSR chip.

Windows 10 find it automatically, no need additional driver and it work well.
I get a picture of remote control here: https://mega.nz/file/h8AkDI4Q#sFYpa00bScC8ehruhAKnXIn27_sUFcdMrgOsCTU1yCI

I don’t know if this helps:

  • after pair with PC and RPi4, I set " Tether by Bluetooth" at my smart phone.-> https://support.google.com/pixelphone/answer/2812516?hl=en
  • At RPi4 windows 10 network connections setting find “bluetooth network connection” and double click it. At devices and prints window, select your smart phone and then click “Connect using->access point”(above you smart phone icon). connection complete. (same as PC side).

At smart phone tether by bluetooth, then at Win10 become https://mega.nz/file/c0IGEYBR#JkM1RuP8T0CZuj0NqDH0qqC4AS9pricQ9DcW3BbMfHk
If not tether by bluetooth at smart phone, then at Win10 become https://mega.nz/file/5gQAya6S#y4dXm9PS-MIZa9fhSK37W8qu6abluNFOcLIux-Lo2aQ