VLC for ARM64 Installer

#1

Anyone else bummed that the VLC for ARM64 download doesn’t have an installer?
Yeah, me too, so, I wrote one, as it’s a lot more convenient to use it this way.
It’s pretty basic, just copies the VLC files to C:\Program Files (Arm)\VideoLAN\VLC\ and sets some common video / audio formats to open with it, along with creating a start menu icon for it.

Here’s the download (Scroll down to Videos and Media)
Just extract all and then right click --> run as administrator on installVLCARM64.bat and you should be good to go!

Note: you’ll probably have to pick “open with” on your video and music files, but you’ll find VLC in the options now.

Note 2X: Start menu shortcut non-functional and doesn’t seem to show up, that’ll work later I promise :wink:

If there are any formats that you need to be linked to VLC, let me know, and I’ll get to work on it.

2 Likes
#2

So, apparently I had the folder under startup when I tried to make the start menu shortcut, yea, not sure how I missed that. It’s fixed now if you want to re-download it, and It’ll delete the startup item

#3

If you load the vlc 64 as an upgrade from x86 it should exe…Use the pre-existing installer if you still have it.You can always re-download.If not I believe you can get it for Win10mobile’s downloads,I have had alot of luck,chopping IOT and all the arm64 projects to fudge the registry to accept my apps.Linaro from way back has a few drivers that function with windows if recompiled.Not too hard.

#4

I don’t understand what you’re saying

#5

You stated that you want vlc64arm to run?If you have the x86 version,there was a installer for it correct?If not you will have get a copy of vlc64,then recompile it with the x86 you already have,then use the installer provided with it.The arm64 can run 64bit natively,but
its still x86 at its core.

#6

Sorry for being confusing.

#7

Just in case I’d want it - is there and uninstaller for this or could we get one if not?

1 Like
#8

I’ll look into putting one together :slight_smile:

#9

Ok, I made one, all it does is delete the files and then try to remove the file association, but it doesn’t work.
You can still always right click --> open with --> choose another app --> use as default
I’ll try and figure out how to fix that, but from what I read online it should be working, I’ll experiment a little to get it working though.

#10

Haha I feel dumb right now. I didn’t even realize that it just copies the files over. Not like I’ll be deleting it anyway. I’ll delete them manually if I ever want to.

#11

Yup it’s pretty simple lol