Tp-link archer T2U driver setup

I am trying to get my T2U wireless adapter working in windows 10
I have installed the driver but its not working and seems like a service is missing

is this possible to get working

no. ask manufacturer for arm64 version of a driver. but that will never happen so. just no.

I did get an x86 driver installed but its not functional
I though there was supposed to be x86 and x64 support in new builds anyway, so I shouldn’t need an arm64 driver

this is my only hope for fixing a networking issue I have had for three months

I need to bridge Wi-Fi and Ethernet it only seems possible in windows
the only device I can use is a raspberry pi 4

I need to make this possible

I need to share a wireless connection across a network cable to another device
I have tried everything to get this working including openwrt
this is my last hope and I am rapidly losing motivation

app emulation isn’t driver emulation. Driver are architecture specific and nothing can be done if u are not an driver dev who would love to waste a lot of time coding a new driver.

how did the driver install then

here is my last hope, I need to convert a wireless network into a wired one
I got it working on a windows laptop by bridging the interfaces, but I need the laptop for other things

this project was my only hope

the manufacturer does not have arm64 drivers and probably never will even if I request it

I wouldn’t know where to start developing a driver, the only thing I can develop is a python script

is there anyway I could do driver emulation

do any usb wireless adapters work with windows on raspberry

this is my only hope for fixing a network issue I have

could I run windows 10 64 bit emulated on windows 10 arm, then pass though the usb wireless adapter

but how would I pass though the ethernet

probably not going to work