Strange Problem with my fritzbox router

Hey guys,

is someone using an fritz router and can reproduce my issue?

If i put the pi on a TP Link switch, i get 15-20 MBs read/write speed.
If i put the pi on the fritz box directly via lan, i get 5 MBs read/write speed.

Any idea why this is happening? The cables and the router are not the problem i doubled checked it with my other linux Pis and they are all working, also the Windows Pi is working but only on a switch with fullspeed.

I simply don’t understand whats causing the slow speeds? I tried it over smb and ftp both the same results.

Ok guys problem solved, the fritzbox has no flow control (and i still no idea how to activate it), with a switch inbetween with activated flowcontrol its working.

The problem was that my PC is sending 1 Gbit of data through the fritzbox and the Pi can’t handle it so the connection goes down to 100 Mbit, with flow control enabled that is not happening because the swtich is handeling the 1 Gbit output of the PC.