Microsoft VC4 graphic render only driver

#21

Hi,

For the redistribuables, it’s better to use static linking for the C++ runtimes. On Qualcomm Windows Phone devices, dynamic linking for those was used at first, but they transitioned to static when making the switch to desktop.

image

When this is shown with the 9_x feature levels, you should be able to run test apps without any further bugs than those present in the IoT Core version of the driver.

Also, I think that using Mesa’s Direct3D 9 support (Gallium Nine) might work better, as Windows 10 still supports WDDM 1.0 with D3D9Ex.

Thanks,

#22

I think that feature list is from the Microsoft basic display adapter, as it’s dated in 06 as basic display adapter driver is usually

#23

why
Why does this point to the DLL so many times in the same line?

edit:
Also, is this build including the changes from here?


Going by https://github.com/Microsoft/graphics-driver-samples/issues/25 That’s what we would need to have Direct2D support, or having windows rendered via the GPU. (at least I’m guessing)

#24

first entry is DX9, then 10, then 11, then 12

I bet that the PR there isn’t included, as it didn’t even reach the MS main branches.

#25

Do we know why? From what I could tell it was updated to all the reviews, but then they didn’t merge it and it fell behind all the commits

#26

It’s only a few commits behind really compared to master, not too far away.

#27

I got the pr driver to compile and its running with ForceWARP set to 0. I am not sure if its working properly though.


EDIT: i noticed that the feature level was not there.

#28

Better?

1 Like
#29

Is that with ForceWARP set to 0? I got the system to come up with it set to that once, but it refuses to give me a screen again.

#30

yes. Now there’s the removing ForceWARP from the post-install bat.

Warning: you need the PR for texture support merged or it’ll get… nowhere.

Also, it’s heavily unstable.

#31

Is that a working build from the PR?
If so I’d love a link to it

#32

I got it working ONCE. I tried 30+ time after. I think it was either a first-try luck or a flucke.

USB Driver Test Results
#33

I ran some youtube & VLC playback test. Here are the results.
youtube & VLC

#34

i installed the driver from https://github.com/woachk/rpigpu/releases but it says error code 43
i think i install c++ runtime 2017 32bit but it still is not working.
what should i do?


@BenNottelling @woachk

#35

Use one of the older builds or you need to find the .bat file lower down the releases folder and install that

#36

used the rosrog.bat file with latest release,first release and 3 other random releases,every single one had this problem
i guess im missing something.
let’s say i have a fresh install
i have to use the .bat file
then install the driver

that’s all or should i do another step to make it work?

#37

Should be all, I know that older versions needed the VS redist, but not the newer ones

#38

Can anybody compile this drivers with MT switch instead of MD?

#39

roskmd.cat and rosumdarm.dll from the original driver build… these are also older drivers than what are on github as I know these ones work

edit: Oh, and I didn’t test to see if these work.