Is it possible to install Windows on ARM on a normal harddrive?

Hey guys short question is it possible to install Windows on ARM on a normal 1 TB usb harddrive (not SSD)? With the Standard WoA Deployer? Or must i mod something?

Because my Windows 10 dies every 3 Month when iam using SD cards, so i want to switch to a normal HDD because it must run 24/7 (backups etc) and iam not really trusting an SSD.

Thanks :slight_smile:

I have used a hard disk before and it totally works, but it’s a better idea to use an SSD, i’m not sure why you don’t trust them.

1 Like

So its working with the Deployer? Just choose the usb drive and then it boots? I thought i use an HDD because of the longtime running and because i don’t need to use the Pi actually, its just made backups automated so i dont need to use it very often just 1-2 times to check if everything is working properly so an SSD would be making not much sense i think.

you can, but you will need a powered USB to SATA adapter for a standard HD, as a standard HD will draw too much power from the USB port and won’t work properly. It’s also going to run slower than just the SD card as well…

Only 3 months for a SD cards ? Thank you for this information, but to my mind, it’s few.
With a sd card, in fact you have to minimize the read/write actions to preserve it, as you talk about backup, is the backup on the sdcard, usb key or network ?
And what kind of back up, simple copy, or synchronisation are you using ?
The fact to use a usb key to save on it, and to make a synchronisation (with rsync by exemple) instead of a single copy (you only copy the data that changes) could be a first interesting solution to your problem, even if it won’t totaly solve it.

@ 5ft24dave

Would that working here? https://www.amazon.de/dp/B06VVS7S94/

@ lariost

Its actually a script, backups my server to my usb drives, so the SD card isnt invovled, only my ftpserver at home (which is running in RAM) and my ftp programm (which is also running in RAM) are involved, not sure why the SD card is corrupted after 3 month i think its just windows 10 with 10000000000000 writing/reading in the background its so annoying, i deactivated almost everything and its still holding just 3 month. And iam tired to reinstall everything every 3 month :smiley: so i was looking for an alternative.

Seems like it isnt working, ive tried the WoA Lite version which didnt even wanted to boot, then i tried the deployer and that worked. Booting did working but now i have an black screen and nothing is happening anymore…

Seems like it makes no sense over usb.

Edit: Now its running but performance with the newest update is the worst ive seen. Seems like thats it, getting a x86 PC iam done with the whole Pi thing sorry but its just a waste of time. Worst OS ive ever seen. Was running 1804 before with 30 % RAM, now i use the same settings on the newes 1909 version and its over 95 % of RAM lol what kind of joke is that? wtf is microsoft doing?

Edit2: Same shit with SD Card, same weak performance. wtf is microsoft doing? Why is the perfomance so shitty compared to older versions?!

Hello, I’ve installed a very recent version 2004 (end of january), and seriously i’ve no change with my previous version, I have exactly the same feeling, and the same %use of memory/sd, with no real change (memory use between 40 and 50%).

Maybe you have to try another version of WOA. Are you sure that you do the right optimisation for pi3 ? Do you use the small optimisation script of BN ?
Because if you don’t use the script, 95% of use of RAM and a high R/W of the sdcard is a normal thing, and as you talked recently about some problemes with corrupted sdcard, maybe all is linked, maybe there’s something that you don’t do correctly.

It was the last WoA version and the last windows final version (not into beta/insider stuff), i dont use any optimisation script, because i disable the stuff by myself but its not working in that version it just turn on again after reboot dont know if this version is broken. It runs unstable as hell never had this before, and both from SD and USB so its clearly the version and not the devices.

Used the latest @BenNottelling Script with compression enabled and the latest windows build

Any ideas? Its still 89 % in idle and i didnt install anything yet lol

I’ve made a quick comparaison with my most recent version of WOA insider.
10 min after the start, everything is under 2 mb of RAM except the task-manager and the Desktopfenster-Manager.

Why is the defender not found in your version?

I have sorted the process like you have done, i’ve search among the processes that takes the most memory, and I didn’t find it, and as “The antimalware Service Executable” takes the most of memory, i’ve searched many times in the global list, but I found nothing at all.
It’s maybe a probleme of “translation” of language as you have german and english, and in mine it’s french and english, maybe it’s translated in french and not in german, it could be the reason that i don’t have made the link between the 2.

What i don’t get i even disabled the defender and i have still this issue, also the “Desktopfenster-Manager” is just the RDP interface, because iam on the Pi over RDP.