How do I change the display resolution?

#1

If you want to downscale the resolution of your display (what you asked):

  1. Hit the ESC key while booting
  2. Navigate to “Raspberry Pi Configuration”
  3. Navigate to “Display”
  4. Change the option “Native resolution” to “Also support resolution list here
  5. Boot into Windows
  6. Display settings should now be controlled completely by Windows.

If you want to disable black borders around the edges of your display (overscan) there are two main ways to do it.

METHOD 1: Use the automatic tool I created (IN DEVELOPMENT, NOT FOR worproject.ml USERS

  1. Download the tool here
  2. Run it in Windows with administrator permissions
  3. Done! Reboot your machine

METHOD 2: Do it manually
You may follow this or read it here:

  1. Open the Command Prompt as administrator
  2. Type “diskpart”
  3. Type “select disk 0” (NOTE: recommended to disconnect all external media before this)
  4. Type “select partition 1” (NOTE: make sure system partitions have not been modified from stock WoA state)
  5. Type “assign letter=b”
  6. Type “exit”
  7. Type “B:”
  8. Type “notepad config.txt”
  9. Add the line “disable-overscan=1” and hit CTRL-S to save the file
  10. Reboot!
    NOTE: To do the inverse of this, use “disable-overscan=0” rather than 1.

For further changes of the display settings, go back to the beginning but set the option “Also support resolution list here” back to “Native resolution”, then your display is now in charge of all changes made to the signal. If your display supports it, you may now go to your display’s settings and set the resolution, aspect ratio, etc.

User Guide for new USB Drivers and Ethernet
#2

I can’t get this to work, even though my monitor supports different resolutions
Anything that may be missing?

edit: also, for people who use WOR, they can plug the SD card into their computer and access the boot partition and make the changes to the config file there, not sure if it works with other tools

#3

The “also support resolution list here” should allow Windows to control that stuff, but if you really need to downscale the display res, I would wait for/if the main GPU driver comes out. If it does, we don’t have to use software rendering and most likely the display will not be stuck with the generic driver and hopefully speed up the display. I’m not sure what’s going right now, but another thing you could try:

This software is super old, but wherever I look it still works fine.

  1. Install http://qres.sourceforge.net/
  2. QRes.exe /x:1280 /y:720
  3. Reboot
  4. Done!

I haven’t tested this, but I don’t see why it wouldn’t work.

#4

The default setting for the UEFI Resolution is that “Also support x, y, z…”
I still can’t controll it. In a perfect world there would be a VPU driver that does controll it.
While GPU Accel cant be easily done, there is a documented way to set the physical and virtual resolutions via the mailbox system. Maybe somebody can write a driver that uses this?

#5

I tried QRes, didn’t work.

Error: The graphics mods is not supported!

#6

Ah, probably because the proper signed driver is not signed. The only way I would think is use “Use native resolution” and control all the display settings in your display panel’s physical buttons, etc.

#7

I’m not sure how many displays have a resolution switch in their options, I don’t think any of mine do, but I’ll look

#8

Yeah, same with me, but it’s possible connecting to a TV with 1080i compatibility or 720p compatibility and editing it’s settings will be your best bet if you really need 720p. You could try buying a 720p/1080i compatible cable, but who knows if the Pi will even know how to use that.

#9

Update:
On new versions of the UEFI you can toggle all the resolutions, allowing you to remove 1080p, 720p, ect from the supported list

#10

I have a display with capactive touch(https://www.waveshare.com/wiki/7inch_HDMI_LCD_(B))
display is 800x480
i have set the settings like this in config.txt(as the manual of display says for raspbian)
hdmi_group = 2
hdmi_mode = 1
gdmi_mode = 87
hdmi_cvt 800 480 60 6 0 0 0

but in settings display says 800x600 and from left and right of the display there is a gap of120 pixels which annoys so much and it messes up the touch screen too.i cant change the display in settings,it’s greyed out
what should i do?
@BenNottelling @JMK19

#11

Select the native resolution.

#12

tried it but doesn’t help

#13

Did you add disable_overscan = 1 in config.txt?

#14

yes i tested that too
it is not overscan
the problem is my display is 800 x 480 and windows change it to 800x600
i dont have black pixels in top and bottom of display
only in left and right which the 120 remaining pixels are empty

this display works out of the box with a normal windows PC and raspbian(with config) so the problem is with the raspberry pi

#15

Try “use native resolution” combined with the disable_overscan and you should be set, the automatic resolution will be used.