Guide to USB-boot with WOA Deployer

#1

This works for me in the Raspberry Pi 3 Model B

  1. Use the latest WOA Deployer
    If you already have it, remove the Downloaded folder inside the application folder. This will force the application to redownload all the binaries.
  2. Deploy WOA to your SSD
  3. Get a fresh SD Card formatted as FAT32 and copy the latest UEFI files. It will be inside the WOA Deployer “Downloaded\UEFI\RELEASE”. The root of the card should look like this:

image

  1. In the card, edit config.txt and put this

arm_control=0x200
enable_uart=1
armstub=RPI_EFI.fd
disable_commandline_tags=1
program_usb_boot_mode=1
disable_overscan=1
max_usb_current=1

  1. Extract the card an put it into your Pi
  2. Boot with ONLY the card until you see the UEFI Shell.
  3. Once it’s booted, turn the Pi off (unplug it)
  4. Plug you SSD to the Pi.
  5. Boot again, press [Escape] and choose to manually boot from you SSD.
  6. After around 5-6 seconds, it should boot off USB.

If this doesn’t work, copy the config.txt of the SD Card to the BOOT partition in your SSD. You can do it using an admin cmd prompt. Go to the WOA Boot drive (called EFIESP) and open it in notepad type “notepad config.txt”. Notepad will open and will let you modify the config. Use the same configuration as the one above.

2 Likes
#2

Why is the EFIESP partition protected in WoA?

#3

To protect people accidentally modifying it, because there’s only stuff you don’t need once booted (except maybe config.txt to fix overscan) in there. They don’t want people copying over windows apps and stuff, booting their pi, and either it not working or they can’t get to it.

#4

Well thanks! Well, I recommend using WoR the first version and adding the USB and Ethernet drivers. On the other hand, the last of WoA if it fails. I do not see any sense in protecting any partition because the raspberry is a development and test board.

#5

How can this problem be solved?

#6

The problem you’re having is caused by you power supply, that doesn’t supply the required amount of energy to power your disk. Try to connect the disk to a powered usb hub or use a psu with more amperage capacity.

#7

Hi, I tried this method but did not work, I get blue screen afteryIUsingh about two minutes trying to boot,using Kingston 60 gb ssd,also tried WDd 2.5 hdd . Any suggestions are much appreciated.

#8

If the BSOD is UNMOUNTABLE_BOOT_VOLUME then it means that your psu isn´t powerful enough to handle your ssd. Try with a powered usb hub.

#9

Using external power supply is also a blue screen

#10

What’s the code of the BSOD?

#11

I am able to boot into usb for more than 20 minutes , pass getting devices ready, then getting ready , after that get That message’you need to click o.k to restart and install windows . After restart , get the same message .I have pie 3B. Using WOA and converter enclosure with power supply.

#12

I think you have either a underpowered power supply (get a better power supply, 2A reccomended but i use 3A, or an incompatible build of Windows. Try both

#13

I am using now the raspberry pi power supply 3A 5v , and managed to get to desktop but when shut down,unable to get to desk top again get the rainbow again, if I use a hub with IA or 2A seperat ps then installation does not complete. My pie is 3B. I am using windows 10 17134 which works very well with sd card and usb flash drive but unreliable with hdd or ssd.

#14

Could just be that your Pi is malfunctioning somehow or your SD Card is corrupt. Try plugging the SD Card back into your PC and running chkdsk (check disk) or right click the drive > right click > Properties > Tools > Check Disk… and see what comes back.