Driver Webstite With Downloads & Info / Status

#1

Hello everyone!
I’ve decided to put together a basic website with the purpose of holding download links, status, and information on the drivers for Windows 10 on the pi.
I don’t host the driver on the site, instead I provide a link to the original download location, but if drivers show up without a compiled download, I’d likely host it here.
Check it out here

I’d really love to build a control panel of sorts for the pi, but I don’t have experience with creating desktop GUI applications, so I may build this website out to fulfill that purpose.

1 Like
#2

Trying to build a list of apps that work well on the pi
http://rpidrivers.bennottelling.com/greatapps/index.php
I’d appreciate if people would mention their favorites so I could add them to the list!

#3

You may want to add my port of Microsoft IoT Core BSP: github.com/driver1998/bsp

also, for apps, you can checkout this thread on XDA:

1 Like
#4

I’ll get around to it soon I swear :slight_smile:
btw, I’m not sure if all of those apps work on ARM64 widows, for example, I tried quake 3 and couldn’t get it working as the VS redist wouldn’t install (unsupported CPU, using arm installer, x86 worked fine, but the game wouldn’t work with those)

#5

Maybe you’ll need to get the individual redist dlls or hack the installer to think it is running on ARM32…

#6

I’ll look into that, if I can figure out how to do it via CMD i’ll put that on the site as well

#7

Ok well, even when I had the DLL in SystemRT, System32, and SysWOW64 it SILL said it couldn’t be found, so I tried planting it into the exe’s folder, at which point it gave a different error about the app not working, but I believe this is because it was a non-arm redist, a 32 bit version instead. I don’t have a windows RT device, and I can’t pull the DLL out of the exe, and I don’t have any clue how to make it think it’s being run under ARM32. If I could get the DLLs from these redists, I think it would work.
Any idea where / how I could obtain these? Google seems to be of no help, and right now I feel like there aren’t enough native ARM64 apps, these would be nice

#8

ARM32 System folder is named SysARM32…

SysWOW64 is for x86 apps

#9

Oh, I didn’t know that.
Still, I don’t have a way to obtain these ARM32 redists as I don’t have a device the installers can work on, and when I tried the 32bit redists, it didn’t work.

#10

VC++ 2012 and 2013 redist is available for download here (vcredist_arm.exe)
2012: https://www.microsoft.com/en-us/download/details.aspx?id=30679
2013: https://www.microsoft.com/en-us/download/details.aspx?id=40784

Which are what the most RT apps uses.

as for 2015 and 2017 (2017 redist is backwards compatiable with 2015), Microsoft didn’t seem to have installers released, but individual runtime DLLs are included in Visual Studio.

You can get a set here if you don’t have VS installed:
https://mega.nz/#!qE0gECLT!SfrbwUamwA9z6XCoN2n-L0WxV41zMvU1w8N2w2CIP8o

#11

No, they don’t install on arm64, that’s my problem, I’m perfectly aware of where they are. Thank you though

#12

Well, I managed to unpack the installer (which turns out to be quite easy with Wix Toolset), and here are the dlls of all versions (2012/2013/2017).

https://1drv.ms/u/s!AueX0eo4NQeRhMxT0C5tFAAad0R61w

1 Like
#13

Thank you!
These just go into the SysARM32 folder, right?

#14

Or copy to the directory of the program EXE.

#15

True, but I’d rather a solution that works for all apps at once

#16

then yes, copy to SysARM32 and it should work

1 Like